2 User Interface

_images/gui-local.jpg

SquidNet Render Manager - Main GUI

The figure above shows a sample screen of SquidNet’s main user interface. The GUI application uses a multiple document interface (MDI) format in which multiple window “views” reside under a single parent window. This MDI format allows for the creation of custom window layouts by arranging the views in any order.

The main GUI is composed of the following sections:

  • 1. Main Menu: Selectable menu items (Project, View, Network, Tools, Admin, Window, Help).
  • 2. Main Toolbar: Quick access buttons for commonly used views.
  • 3. Status Bar: Overall summary of render farm status (Queued jobs, nodes online, uptime, etc…)
  • 4. View Windows: Selectable windows placed anywhere within the appplication background screen.

The figure above also represents a typical layout of render farm views:

  • Project Folder View: List of project job profiles (Project->Project Manager).
  • Job Queue View: Shows queued jobs (Tools->Job Queue).
  • Image Preview View: Shows output folder contents by clicking on queued job (Tools->Image Preview).
  • Render Farm CPU Nodes View: Lists all render farm nodes and their status’ (Network->Render Farm).
  • Render Farm Work Queue View: Lists active render nodes and the jobs they’re working on (Network->Network Work Queue).

To start the SquidNet user interface:

Windows: Look for “SquidNet User Interface” in main start menu or look for the SquidNet icon on your desktop. Installed under “C:Program Files (x86)SquidNetSoftwareSquidNetsquidnet-ui.exe”

Mac OS: Open /Applications/SquidNetSoftware/SquidNet/squidnet-ui.app/Contents/MacOs/squidnet-ui

Linux: Open /opt/squidnet/squidnet-ui.sh

Tip

To create and load/save custom view layouts, use the Custom Layouts Manager (Window->Customer View Layouts)

2.1 Project Menu

2.1.1 Project Manager

_images/project_manager.jpg

Project Manager

For local jobs, SquidNet stores all job profiles inside of project folders. Open the project folder (Project->Project Manager …) to create or select specific project folders. Project folders and their content is stored in the SquidNet configuration folder.

_images/project_folder.jpg

Project Folder

Project folders contain all your job profiles. When a new job is submitted to the farm, you’ll be asked if you’d like to save it to the local project folder. Saving of job profiles is recommended if you’d like to reopen a previously submitted job, adjust a few rendering parameters then resubmit.

Project folder options are as follows:

  • Project: Select a new project folder.
  • New Job: Create a new job.
  • Submit: Submit selected job profiles then submit to the farm.
  • Refresh: Refresh job profile list.
  • Template: Only list specific applicaton types within the folder.
  • Filter: Filter job profiles by text.

2.1.2 Job Profile

_images/job_template.jpg

Job submission from template form.

Creating a new or opening an existing job profile in the Project folder window opens up an application template. The template contains all the rendering parameters for a specific job type.

Job template field descriptions:

  1. Template: The type of application that will process this request:
  2. Project folder: The project that this job will belong to.
  3. Scene/shot name: Name of the shot that this scene belongs to. By default, all scenes belong to the “Default” shot. Use the “+” or “-“ buttons to the right of the shot name to add or remove shot names to/from the list.
  4. Auto-generate job id: Press repeatedly to regenerate new job id.
  5. Use scene name: Extract the scene name and use that name as the job id,
  6. Job id: Identifier used to track job on the farm.
  7. Description: Brief sentence describing scene.
  8. Max Slices: The maximum number of active job slices. Defaults to distribute as many slices as possible.
  9. Use all cores: If checked, use all available cores for each job slice.
  10. Slice Timeout (multiplier): Automatically requeue any job slice that exceeds the average processing time of the other slices within the same job.
  11. Start Suspended: Initially queue job into a suspended state.
  12. Slice Timeout (mins): Automatically requeue any job slice that exceeds a specific rendering time (in minutes).
  13. Randomize job slices: Randomly process job slices (as apposed to processing sequentially (default)).
  14. Slice fails before stop: Set the maximum number of allowed per-job slice errors before job processing is halted.
  15. Skip frame: Don’t process frames that already exist in output folder.
  16. Check output content: Verify that output folder contains rendered content. If not, error out job.
  17. Create output folder: If not present, create output folder directory.
  18. Frame Check: Automatically requeue missing or corrupted output frames.
  19. Estimate Completion Time: Just render a single frame to determine total job completion time.
  20. Priority: 25 different processing priorities (0-24). “0” being the highest priority and 24 being the lowest.
  1. Render Pools: Assign render pool(s) to this job.
  2. Include/Exclude: Assign jobs to ONLY render on specific nodes or to NOT render on specific nodes.
  3. Tile Rendering: Tile render settings.
  4. Advanced: Advanced job settings.
  5. On Job Completion:: Dispostion options when job completes.
  6. Submit: Submit job to farm.
  7. Apply: Submit job to farm but leave submission window open so that adjustments can be made to rendering parameters.
  8. Save: Save job profile and close submission window.
  9. Cancel: Undo all changes and close submission window.

2.2 Tools Menu

2.2.1 CPU Render Farm

_images/render_cpu_nodes.jpg

Render Farm CPU Nodes

The CPU render farm nodes window (Tools->CPU Render farm) lists all the render nodes available on the farm. Within this window, all render node operations are performed.

The top status line contain current farm node statistics: Active, online, busy, offline, etc…

Dropdown lists for filtering on specific nodes types: Pool, State, Operating System and node type. Also includes quick access push buttons for master configuration, lock, lock-now, unlock and exceptions list.

Right-clicking on any of the nodes opens the menu selection options:

  • Configuration:
    • Set As Master: Configure selected node as a master.
    • Set As Client: Configure selected node as a client.
    • Set As Slave: Configure selected node as a slave.
    • Configure Master: Setup master node settings.
    • Configure Client: Setup client node settings.
    • Change SSA Account: Change SquidNet System Account (SSA). Windows only.
    • Change Log On Account: Change log on account. Windows only.
    • Assign Alias name: Provide an alias name to a render node.
    • Add Node: Add a node to the nodes database. Use if attaching nodes from outside the local subnet.
    • Remove Node: Remove selected node from nodes database.
    • Force node connection: Attempt to connect nodes from external subnet.
    • Remove offline nodes: Remove selected nodes from nodes database.
    • Network Interface Select: Select default network interface to use. Typically, only one network interface should be enabled.
    • Upgrade Software Version: Update selected nodes to latest SquidNet software version.
  • Render Node Log: Nodes activity log.
    • Powerup Render Farm: Wake up render farm by sending Wake-on-lan messages to all render nodes.
  • Availability:
    • Restart Render Farm: Reboot all render farm nodes. Master node is not rebooted.
    • Shutdown Render Farm: Shutdown all farm render nodes.
    • Reboot: Restart selected nodes.
    • Shutdown: Shutdown selected nodes.
    • Standby: Place selected nodes in standby mode.
    • Hibernate: Place selected nodes in hibername mode.
    • Reboot when idle: Restart selected nodes when they become idle (not working on active jobs).
    • Shutdown when idle: Shutdown selected nodes when they become idle (not working on active jobs)
    • Wake-on-lan: Wake up selected nodes with WOL messages.
    • Schecdule: Setup schedule for when selected nodes is allowed to process jobs.
    • Lock: Prevent selected nodes from processing any jobs. Any active are allowed to complete.
    • Lock now: Cancel any active jobs on that node before locking it.
    • Unlock: Allow selected nodes to resume processing tasks.
  • Exceptions:
    • : Show error messages from selected nodes.
    • : Clear error messages on selected nodes.
    • : Clear error messages on all farm nodes
  • History:
    • Job queue: Show completed jobs on the farm (master only)
    • Work queue: Show jobs processed on selected nodes (clients and slaves only)
  • Detach: Remove window from main GUI and display as a seperate window outside the GUI interface.
  • Set status note: Set or get the status of selected render nodes.
  • Set comment: Add a small commment to render nodes. Comment is displayed as a column field.
  • Properties: Show property list for selected node.
  • Select Columns: Determine which columns are visable in window.

2.2.2 GPU Render Farm

_images/render_gpu_nodes.jpg

Render Farm GPU Nodes

The GPU render farm nodes window (Tools->GPU Render farm) lists all the render nodes on the farm that contain GPU graphics cards. Right-clicking on any display item will enable or disable a GPU card.

2.2.3 Job Queue

_images/job_queue.jpg

Render Farm Job queue

The farm job queue window (Window->Job Queue) displays active jobs. The image above shows the active job queue (left panel) and a list of slices for the selected job (right side). Right->clicking inside the window displays the following menu options:

  • Job Request: Display the submitting job request.
  • Job Slices: Open the job slice window for the selected job.
  • Priority: Adjust job’s rendering priority.
  • Job Log: Open job’s activity log.
  • Suspend: Suspend the selected job. The job will be suspended immediately after any active job slices complete.
  • Suspend now: Cancel the select job immediately and place in a suspended state.
  • Resume: Resume suspended job.
  • Render Now: Place the select job to the highest priority. Any active jobs already rendering are requeued.
  • Restart Error Jobs: Restart jobs in an error state.
  • Clear node exclusion list: Clear list of render nodes that were automatically excluded from the job’s rendering workflow.
  • Cancel: Cancel job and terminate any active job slices.
  • Images: Open image preview window.
  • Output Folder: Open host folder explorer.
  • Detach: Remove window from main GUI and display as a seperate window outside the GUI interface.
  • Set Comment: Set small note or comment.
  • Properties: Show property list for selected node.
  • Select Columns: Determine which columns are visable in window.

2.2.4 jobslice Queue

_images/jobslice_queue.jpg

Job Slice Queue

The job slice queue window (in local job queue select job, right-click then select “Job Slices” ) displays slices for the selected job. Right-clicking within the window will present the following options:

  • Requeue: Requeue the selected job slice.
  • Abort: Cancel the select slice and leave in an abort state.
  • Hold: Do not render this job slice.
  • Release: Release the hold on this job slice.
  • Exclude from job: Prevent node that rendered this slice from rendering another job in the same job.
  • Include in job: Clear this node from the exclusion list.
  • Clear Memory Recall: Clear the list of nodes that caused low-memory errors.
  • Images: Open image preview window.
  • Application Render Log: Open the current application render log.
  • Select Columns: Determine which columns are visable in window.

2.2.5 Work Queue

_images/work_queue.jpg

Render Farm Work Queue

The farm work queue window (Window->Work Queue) displays active render nodes and jobs that that they’re working on. Right-clicking within the window will present the following options:

  • Requeue Job Slice: Cancel the current jobslice and requeue.
  • Application Render Log: Open the current application render log.
  • Detach: Remove window from main GUI and display as a seperate window outside the GUI interface.

2.2.6 Image Preview

_images/image_viewer.jpg

Image Preview Window

The image preview window (Tools->Image Preview) display the images in your job’s output folder. Simply click on any job in the project window or job queue to display the output images. If multiple image sequences are found in the folder, select range in the dropdown list. Push the play button or move the slider to scroll thru animation sequences.

2.2.7 Image & Sequence Viewer

_images/image_seq_viewer.jpg

Image & Sequence Viewer

The image and sequence window (Tools->Image and Sequence Viewer) provides you the ability to view image sequences in the selected folder. Use the available controls to scroll thru your image sequences.

2.3 Charts Menu

2.3.1 Render Farm CPU Usage

_images/chart_gpu_usage.jpg

Render Farm CPU usage

The CPU usage chart (Charts->CPU/Memory usage) shows CPU usage for your entire farm of for a specific node. Double-clicking on the chart will present the following options:

  • Clear: Clear graph.
  • Detach: Remove window from main GUI and display as a seperate window outside the GUI interface.
  • CPU: Toggle CPU graph.
  • Memory: Toggle MEMORY graph.
  • Cores: Toggle CORES graph.
  • Details: Toggle DETAILS display.
  • Node selection: Select entire farm or specfic render nodes.

2.3.2 Render Farm Network Map

_images/chart_network_map.jpg

Render Farm Network Map

The network map (Charts->Network Map) shows the layout of your render farm.

2.3.3 Render Timeline

_images/chart_timeline.jpg

Render Farm Render Timeline

The render timeline (Charts->Render Timeline) shows a graphical representation of the jobs rendered on your farm.

2.3.4 Render Farm Job Queue Stack

_images/chart_job_queue.jpg

Render Farm Job Queue Stack

The job queue stack chart (Charts->Job Queue Stack) shows a graphical representation of your render farm’s job queue.

Attention

Depending on your render farm size, displaying some of the graphic windows may affect overall GUI performance.

2.4 Admin Menu

2.4.1 Master Configuration

_images/configuration_path.jpg

Master Configuration

The Master configuration window (Admin->Master Configuration…) contains settings that are specific to the master node. These settings can only be modified on the master node.

Basic settings:

  • Operating System Configuration Path: Network path for all SquidNet settings, job profiles, etc…
  • Queuing Method: Deterines algorithm used when jobs are queued with the same priority.
  • Master is allowed to process jobs: Although not recommended, select to include the master node in the rendering pipeline.
_images/master_advanced.jpg

Master Advanced Settings

Press the “Advanced” button to open up the advanced settings.

Advanced settings:

  • Network Connection Timeout: Amount of time (in seconds) to wait before the server reattempts nework TC/PIP or UDP connections.
  • WOL Delay Time: Wake-on-Lan (WOL) delay between messages sent to render farm nodes. Use this setting to avoid power surges when starting all farm nodes at the same time.
  • Job Delay Before Submit: Wait some time before submitting jobs to the farm. Used to offset the loading of rendering content from network storage.
  • CPU Delay Before Submit: Same as Job Delay Before Submit but CPU job specific.
  • GPU Delay Before Submit: Same as Job Delay Before Submit but GPU job specific.
  • Slice Log File Size: The default render log size for slices returned from render nodes.
  • Mac OS Render Account: The user account used to render job slices on Mac OS slaves.
  • Linux Render Account: The user account used to render job slices on Linux slaves.
  • Use Session ID 1: Use alternate session id for jobs rendering on Windows hosts.
  • Auto reset slave node timeouts: If configured, reset slave shutdown timeout periods to 1 hour. (Automatically resets at midnight)
  • Disable server startup recovery: Upon master node startup, the server will attempt to re-acquire the status of any rendering jobs. Check this option to disable this feature.
  • Allow concurrent CPU and GPU rendering: If rendering both CPU and GPU jobs and if the farm has adequate resources (memory, etc…), select this option.
  • Ignore node that create slice errors: For a specific job, ignore nodes that create rendering errors. These nodes will not be part of the rendering pipeline for remainder of the jobs time in the render queue.
  • Enable watchdog process: Start background watchdog process that monitors the status of the master server. The watchdog will automatically restart the main SquidNet service if communications to it are lost.
  • Enable multi-user accounts: For local render farm users, select this to force user login from SquidNet Client nodes.

2.4.2 Preferences

The preferences window (Admin->Admin Preferences…) allows you to setup basic job configration settings.

_images/pref_config.jpg

Configuration Preferences

Selecting “Configuration” on the left will display some local configuraion items:

  • Configuration Path: The SquidNet configuration path for the local node. (see Master Configuration section).
  • Enable Splash Screen: Enable/disable displaying of SquidNet splash screen when the main interface is started.
  • Enable System Tray Agent: Enable/display the display of notification messages from the system tray agent.
  • Wakeup Render Nodes…: Wake up (WOL message) render nodes when jobs are submitted.
  • Idle node shutdown: Automatically shutdown render nodes when they become active for a specified period of time.
  • Queue Display Size: Determine the number of visable item rows in the jobs and slice windows.
  • Video Playback: Path to program that plays back videos generated from image sequences. (as setup in job request)
_images/pref_templates.jpg

Configuration Preferences

Selecting “Job Submission” on the left will display some job configuration items:

  • Template Selection: Determine which application templates will be available in the job submission window.
  • Sound Clips: Play sound clips for specific job workflow events.
  • Job Slice Stall Limit: Detemine the stall limit for a job slice. If limit is reached, slice is automatically requeued.
_images/pref_notifications.jpg

Configuration Preferences

Selecting “Notifications” on the left will display checkboxes for job notifications events that are sent to the local user interface.

2.4.3 Application Path Manager

_images/app_profiles.jpg

Application Profiles

Application profiles (Admin->Path Configuration->Application Path Manager …) contain the installation of known rendering applications.

2.4.4 Application Path Scanner

_images/app_path_scanner.jpg

Application Path Scanner

The application path scanner (Admin->Path Configuration->Application Path Scanner …) allows for the detecton of 3d applications installed on your render far.

2.4.5 Path Translation Manager

_images/path_translation.jpg

Path Translation Manager

The path translation manager (Admin->Path Configuration->Path Translation Manager …) sets up network path mappings between different operating systems.

2.4.6 Mapped Drive Manager

_images/mapped_driver_manager.jpg

Mapped Drive Manager (Windows Only)

The mapped drive manager (Admin->Path Configuration->Mapped Drive Manager …) sets up the automatic mapping and mounting of Windows network shares during the rendering process.

2.4.7 Render Farm Accounts

_images/renderfarm_accounts.jpg

Local Render Farm Accounts

The render farm account window (Admin->Renderfarm Accounts …) manages user accounts for the local render farm only (ie; local studio account name is “Renderfarm”). Press the “Create new render account” button to create a new account.

_images/renderfarm_account_add.jpg

Local Render Farm Account Add

Local Renderfarm accounts can have the following settings:

  • Administrator Account: User is provided with the same admin permissions as the user on the SquidNet master node.
  • Private Job Storage: User has their job profiles stored in a private subfolder in the SquidNet configuration path. By default, all users share the same job profile subfolder structure.

Cloud Renderfarm accounts can have the following settings:

  • Manage other jobs: Has permission to alter job activities from other users.
  • Has Admin Priviledges: Has permissions to act as administrator. (ie; same permissions as administrator account)

2.4.8 Email Setup

_images/email_config.jpg

Email configuration.

SquidNet provides email notifications for specific workflow activities. These activities can include:

  • Job completion/cancellation
  • Job errors
  • Admin reports
  • SQL query reports.

To configure your settings, open the email setup window (Admin->Email Setup), then set the following settings:

  • SMTP Server: URL of email SMTP server.
  • Port Number: Server port number fo connect to.
  • Account: Server login account.
  • Sender: Server login account. (Typically the same as account address)
  • Password: Server login password.

Once setting are in place, press the “Test” to confirm the settings. If successful, press “Apply” to save your settings.

Tip

Pressing the “Test” button sends a test email to the specified SMPT server. You will not be allowed to save your settings until a test email is successfully sent.

2.4.9 Cloud Interface

_images/cloud_interface.jpg

Main Cloud Interface Window

If you have a SquidNet Render Farm Service license, this is the main configuration interface (Admin->Cloud Interface …) for all cloud-related settings. See Cloud Configuration Interface section for additional information.

2.4.10 Pool Manager

_images/pool_manager.jpg

Pool Manager Window

The Render Pool Manager (Admin->Pool Manager …) is used to combine slave nodes into specific groups of render nodes that perform specific actions.

_images/pool_manager_edit.jpg

Pool Manager Add/Edit Window

2.4.11 Script Manager

_images/script_manager.jpg

Script Manager Window

The script manager (Admin->Script manager …) is used to manage the automatic execution of user-defined scripts. The execution of the scripts can be arranged in the following methods:

  • Job: Execute scripts before jobs start/complete and before/after slice start/completion.
  • Deployment: Setup scripts to deplot software updates to the render farm.
  • Maintance: Setup render farm maintanence scripts to automatically deplay at specific times of the day/week or month.
  • Template: Setup scripts to execute based on the application template type.
_images/script_manager_add.jpg

Script Manager Add/Edit Window

2.4.12 On Condition Profiles

_images/oncondition_profiles.jpg

OnCondition Profiles Window

The OnCondition profile manager (Admin->On Condition Profiles …) is used to perform workflow-related actions when specific job conditions are encountered.

_images/oncondition_profiles_edit.jpg

OnCondition Profiles Add/Edit Window

2.4.13 Environment Variables

_images/env_var_manager.jpg

Environment Variables Manager Window

The environment variables manager (Admin->Environment Varialbles …) is used to setup the automatic creation of environment variables before any job slice starts to render. You can setup variables to execute on all nodes or on specific rendering platforms (Windows, Mac OS or Linux). The variables defines are global to all jobs queued on the farm.

_images/env_var_manager_edit.jpg

Environment Variables Manager Add/Edit Window

2.4.14 Meta Log Manager

_images/metalog_manager.jpg

Meta Log Manager Window

The meta log manager manager (Admin->Meta Log Manager …) is used to retreive specific application logs from the rendering nodes. Each meta log profile determines which meta-data log on the rendering node to retrieve and display in the job slices window.

_images/metalog_manager_create.jpg

Meta Log Creation Form

2.4.15 Render Exception Manager

_images/render_exception_manager.jpg

Render Exception Manager Window

The render exception manager manager (Admin->Render Exception Manager …) is used to send users recommendation notifications about exceptions detected in submitted jobs.

_images/render_exception_manager_create.jpg

Render Exception Creation Form

2.5 Window Menu

2.5.1 Relocatable Status Bar

_images/statusbar_top.jpg

Status Bar on top

_images/statusbar_left.jpg

Status bar on left.

The status bar can be repositioned on any side of the main GUI (top, bottom, left, right). To reposition, selct the upper-left portion of the status bar then drag to either side of the GUI. Positionining outside of the application is also possible.

2.5.2 Tile Windows

_images/window_view_tiled.jpg

Tiled Views

2.5.3 Cascade Windows

_images/window_view_cascaded.jpg

Cascaded Views

2.5.4 Customer View Layouts

_images/gui-custom-views.jpg

Custom View

Use the Custom View Dialog (Window->Custom View Layouts) to define your custom window arrangements within the main GUI.

2.5.5 Tabbed View

_images/gui-tabbed.jpg

Tabbed Views - Main GUI

The figure above shows the main GUI in tabbed mode where each window view appears in a separated tab. Use the (Window->Tabbed View) of main toolbar button to toggle between tabbed and window modes.

2.5.6 Close All Windows

Select this menu option to close all opened views.